New Java version release of NCIS

After 12 months hard work, the NCIS technical team has successfully launched the latest version of NCIS.   As part of

New Java version release of NCIS

After 12 months hard work, the NCIS technical team has successfully launched the latest version of NCIS.   As part of a modernisation strategy, the interface has been rewritten using Java to ensure that NCIS will continue to innovate into the future while mitigating the risk of using proprietary code.

When you first login after the upgrade, you will be required to change your password.  You will notice that password strength is now enforced.

While every effort has been made to fully test the new version of NCIS, changes of this size invariably come with some bugs and it is important that you report these to us so that we can fix them ASAP.

If you do happen to find an issue, please send an email to ncis@ncis.org.au and provide us with as much information as possible.

Compatible Web Browsers
While we have attempted to accommodate the various versions and types of browsers used by most parties, significantly older browsers do not conform to current web standards. As such they cannot be guaranteed to work correctly with modern websites.
The NCIS will be able to be supported on the following browsers;

  •  Internet Explorer versions 8, 9 or 10 (with a preference for 9 or 10)
  •  Firefox 5+ (preferably above 20)
  •  Chrome (recent releases)
  •  Safari 5+

Users will still be able to login with older versions of the listed browsers or other browsers but will receive a pop-up warning informing them that their browser isn’t supported and that the NCIS Unit will not be able to assist with any problems encountered.

Feel free to contact the NCIS Unit on 03 9684 4414 with any queries that you have in relation to the system uppgrade.

Comments are closed